Custom dataset split


#1

Hi there again
I just wanted to train a new model with a 90%/10%/0% split for the dataset (train, val, test). But my accuracy wont improve, even tho it should. i already trained it with a predefined 80%/20%/0% split. how can i solve this?
regards
UPDATE
I literally changed nothing. but it works now. which seems strange
UPDATE 2
So now i did the same split as you guys did. 80/20/0. custom of course. first of all, the validation set seems to be the training set, because an epoch takes about a quarter of a time as before and there are way more validation accuracies than accuracies. i cant reconstruct the old state.
i ran four additional models, all of them got the same structure as the original one.
Run10 is the dataset splitted with your split option
following are the custom splitted runs:
Run32 - load full dataset - shuffle off
Run33 - load full dataset - shuffle on
Run34 - load one batch at a time - shuffle off
Run35 - load one batch at a time - shuffle on





do you have any ideas how i could fix this?
thanks in advance
update 3
I cant even reconstruct the old model with the same settings. dont know whats goin on.


#2

Hi Bratwolf,

Have you compared the config (configuration sub tab on results tab) of Run 10 and other runs ?

That should display the difference between the runs if there was any.

Secondly, you should be able to restore to Run10 from model tab, if you would like to go the same settings you had in Run10.

Regards


#3

Did do that. all the configurations are the same. there is literally no difference but the custom split setting.
But i tried to rerun Run10 with the exact same configuration, and the results were the same as Run33 and so on, so i guess the problem lies somewhere else