"Deep Learning Studio is starting" never ends


#1

Please help,

I installed DLS v2.6.0, desktop, Windows 10.

After install, opened primary interface, clicked “Start”.
The message: “Deep Learning Studio is starting” shows up, but never ends.
First time, there was a message about downloding datasets. Ok, waited.
Now, log says datasets are already downloaded.
But still nothing happens.

Tried many times, restarted computer, but nothing happens, always showing thiat message “Deep Learning Studio is starting”.

=== LOG MESSAGES ===

Starting Deep Learning Studio...

Checking GPU support…
GPU not supported
skipping cifar dataset download!
skipping IMDB dataset download!
skipping MNIST dataset download!
skipping reuters dataset download!
loading initial db
/home/app/start.sh: line 110: 7776 Segmentation fault ./manage.py makemigrations --noinput
/home/app/start.sh: line 110: 10296 Segmentation fault ./manage.py loaddata initialdb.json
Using MXNet backend.
/home/app/start.sh: line 146: 5400 Segmentation fault python -u server.py
/home/app/start.sh: line 146: 10572 Segmentation fault olympus up --no-debug --port 6666 --host 127.0.0.1
Starting server worker…

Server worker has been started. [ID: 1 | PID: 10220]

[I 22:05:13.095 NotebookApp] Serving notebooks from local directory: D:\DeepLearningStudio\data\1
[I 22:05:13.095 NotebookApp] 0 active kernels
[I 22:05:13.095 NotebookApp] The Jupyter Notebook is running at:
[I 22:05:13.095 NotebookApp] http://127.0.0.1:8771/?token=
[I 22:05:13.095 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
Server worker is ready to accept messages. [ID: 1 | PID: 10220]

[2018-04-18T01:05:25.204Z] INFO: Theia/10220 on NOTE-gggg: Theia app listening on http://0.0.0.0:8774. []

Received message which is neither a response nor a notification message:
“8774”

[2018-04-18T01:05:25.915Z] INFO: Theia/10220 on NOTE-gggg:
[nsfw-watcher: 10572] Started watching: d:\DeepLearningStudio\home\theia\examples\browser\package.json
[]


#2

Hi tagwato,

Seems like some process are segfaulting during startup. It is likely because there is another Python installation in system PATH which is interfering.

Could you remove your existing Python installation from system PATH and restart deep learning studio and manager (you may have to close deep learning studio manager from windows tray)?

Regards
Rajendra


#3

Bingo!
There was another python installation in system PATH.
Removed and now DLS is working.
Tks.


#4

Thanks for confirming. We will fix this issue in upcoming release so that you do not need to make change in system PATH.


#5

hi @tagwato,could you please tell me how you remove your existing Python installation from system PATH

thanks in advance


#6

Sure.

You can follow one of these steps to set the PATH in Windows systems:
https://www.computerhope.com/issues/ch000549.htm

You should delete any python or anaconda folder from the current PATH environment variable (BUT, wait…keep reading).

Be aware that changing system or user PATH would impact all the programs you run, so I do NOT recommend to modify the PATH that way.

So, what I have done was to build a small RUN.BAT file, with these lines:

rem – clean PATH (adapt according to your DLS folder)
set PATH=%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;D:\DeepLearningStudio\manager

rem – call DLS
deep-learning-studio-manager.exe

After that, I made a shortcut pointing to that RUN.BAT file, which I use to start DLS.

dls-shortcu


#7

This issue has been fixed in 2.0.7 version which is now available on our website.


#8

no sir, the issue remain the same i’m using 2.0.7 but still it is showing me deep learning studio starting


#9

Still having this problem myself, except the datasets don’t even download.


#10

I am installing DLS 2.5.0 on Windows 7 into C:\Program Files\DeepLearningStudio, it pop up error CreateProcess failed, code 267. I checked the virtualenv directory is not created, so it cannot run C:\Program Files\DeepLearningStudio\virtualenv\mmdnn\Scripts\python.exe

I run DLS and get stuck at never ends looping, here is my log:

Starting Deep Learning Studio…
Checking GPU support…
GPU not supported
skipping cifar dataset download!
skipping IMDB dataset download!
skipping MNIST dataset download!
skipping reuters dataset download!
No changes detected
Using MXNet backend.
C:\Program Files\DeepLearningStudio\conda3\lib\site-packages\allauth\account\templatetags\account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
DeprecationWarning)
C:\Program Files\DeepLearningStudio\conda3\lib\site-packages\allauth\socialaccount\templatetags\socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
" {% load socialaccount %}", DeprecationWarning)

Please help. thanks.

warmest regards,
suryadi


#11

Kindly check the pre-requisites of DLS here.
DLS is compatible with Windows 10.