GPU not detected in DLS 2.1.0

I downloaded the DLS 2.1.0 on my win10 on other machine as I was having troubles on ubuntu, I have never installed CUDA before on this system, I installed CUDA using deep cognition setup only but still my GPU is not being detected.
These are the logs

Starting Deep Learning Studio…
Checking GPU support…
GPU not supported
skipping cifar dataset download!
skipping IMDB dataset download!
skipping MNIST dataset download!
skipping reuters dataset download!
Using MXNet backend.
C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\account\templatetags\account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
DeprecationWarning)
C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\socialaccount\templatetags\socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
" {% load socialaccount %}", DeprecationWarning)
No changes detected
Using MXNet backend.
C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\account\templatetags\account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
DeprecationWarning)
C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\socialaccount\templatetags\socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
" {% load socialaccount %}", DeprecationWarning)
Operations to perform:
Apply all migrations: account, admin, auth, authtoken, automl, contenttypes, environments, project, projects, reversion, sessions, sites, socialaccount
Running migrations:
No migrations to apply.
Using MXNet backend.
Using MXNet backend.

  • Running on LINK/ (Press CTRL+C to quit)
    Starting server worker…

Server worker has been started. [ID: 1 | PID: 40812]

[08/Jul/2018:02:00:17] ENGINE Bus STARTING
[08/Jul/2018:02:00:17] ENGINE Serving on LINK
[08/Jul/2018:02:00:17] ENGINE Bus STARTED
[I 02:00:34.008 NotebookApp] Serving notebooks from local directory: C:\Users\Bharat\Documents\DeepLearningStudio\data\1
[I 02:00:34.008 NotebookApp] 0 active kernels
[I 02:00:34.008 NotebookApp] The Jupyter Notebook is running at:
[I 02:00:34.008 NotebookApp] http://127 .0. 0. 1: 8886/?token=…
[I 02:00:34.008 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
Server worker is ready to accept messages. [ID: 1 | PID: 40812]

[2018-07-07T20:30:43.184Z] INFO: Theia/40812 on ratcoder: Theia app listening on http://0.0.0.0:8889. []

Received message which is neither a response nor a notification message:
“8889”

[2018-07-07T20:30:43.951Z] INFO: Theia/40812 on ratcoder:
[nsfw-watcher: 44208] Started watching: c:\Users\Bharat\Documents\DeepLearningStudio\home\theia\examples\browser\package.json
[]

C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\account\templatetags\account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
DeprecationWarning)
C:\Users\Bharat\Documents\DeepLearningStudio\conda3\lib\site-packages\allauth\socialaccount\templatetags\socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
" {% load socialaccount %}", DeprecationWarning)

My GPU - GeForce GT 520MX

The output of .\conda3\python .\home\app\gpucheck.py is
Using MXNet backend.
[02:16:07] C:\projects\mxnet-distro-win\mxnet-build\dmlc-core\include\dmlc/logging.h:308: [02:16:07] C:\projects\mxnet-distro-win\mxnet-build\src\storage\storage.cc:113: Compile with USE_CUDA=1 to enable GPU usage
Checking GPU support…Not supported
simple_bind error. Arguments:
Input_1: (10, 1)
[02:16:07] C:\projects\mxnet-distro-win\mxnet-build\src\storage\storage.cc:113: Compile with USE_CUDA=1 to enable GPU usage

To use GPU, you need a newer card with compute capability >= 3.0. See the list here

GT 520MX cuda compatibility is 2.1

So what does it mean, that I can’t use CUDA or for training compute capability should be>= 3.0, since GT 520MX is actually CUDA compatible, here https://www.geforce.com/hardware/notebook-gpus/geforce-gt-520mx it is given it is CUDA compatible and on my other system which is having less RAM but same GPU, DLS was able to detect GPU on ubuntu which I mentioned in an earlier thread.
System Hangs when DLS is started on Ubuntu

Deep Learning libraries are compiled with some minimum CUDA compute capability. As new version of these libraries are released, they include support for new GPU cards and drop support for old cards.

For example, tensorflow requires compute capability >=3.0 here(https://www.tensorflow.org/versions/r1.0/install/install_sources).

If you were able to see GPU supported on Linux, that means that MxNet linux build supported >= 2.0 cuda compute capability while windows build does not include support for old cards.