GPU supported but not used


so after having some trouble installing DLS properly I finally got to the point where the DLS-Launcher says “GPU supported” but in training it does not use the GPU at any time.

I append the DLS-Launcher-Log and a Screenshot showing the GPU not beeing in use.


Starting Deep Learning Studio…
> Checking GPU support…
> GPU supported
skipping cifar dataset download!
skipping IMDB dataset download!
skipping MNIST dataset download!
skipping reuters dataset download!
No changes detected
Using MXNet backend.

Hi Schockadin,

please type in browser and let me know what output you see.

So it says “gpus: 0”

Having the same issue.
Tried downgrading graphic drivers to 440.97.

-Cuda 9 with Cuda10 bin copied in
-Detects but not used

Can you please check if nvml.dll is present in C:\Program Files\NVIDIA Corporation\NVSMI ?
If it’s not there then Copy nvml.dll from c:\Windows\System32. You’ll have to create the NVSMI folder.

let me know if it works for you.

Yes, it worked. The folder (and thus the nvml.dll) was missing. Thanks. The status now correctly shows “gpus: 1” and the training does use it now.

Thank you santosh, that helped me too.

The Folder C:\Program Files\NVIDIA Corporation\NVSMI was missing
and i copied nvml.dll from c:\Windows\System32 into it, as you described.

Now it is using my GPU RTX2060 with cuda 9.0.
And as i estimate it runs about 20times as fast as before.

1 Like