ImportError: No module named 'plateform'

hey there.
i literally cant do anything anymore because of a ImportError: No module named ‘plateform’
all i did was updating the nvidia driver since it didnt work anymore.
how can i fix this?

Bratwolf, when do you get this error ? If you have full stack trace, please share.

Also what is the DLS version you are running (docker images|grep deep-learning-studio)?

Im using DLS 2.1.0
this is my stack-trace:

Starting Deep Learning Studio…Starting redis-server: redis-server.

  • Starting nginx nginx
    …done.
    Checking GPU support…GPU supported
    skipping cifar dataset download!
    skipping IMDB dataset download!
    skipping MNIST dataset download!
    skipping reuters dataset download!
    Migrations for ‘projects’:
    projects/migrations/0001_initial.py:
    • Create model Project
      Migrations for ‘project’:
      project/migrations/0001_initial.py:
    • Create model dataModel
    • Create model deepModel
    • Create model importModel
    • Create model paramsModel
    • Create model testModel
    • Create model trainingModel
      Migrations for ‘automl’:
      automl/migrations/0001_initial.py:
    • Create model AutoMLModel
      Migrations for ‘environments’:
      environments/migrations/0001_initial.py:
    • Create model EnvironmentModel
      Using MXNet backend.
      /usr/lib/python3/dist-packages/pandas/init.py:7: DeprecationWarning: bad escape \s
      from pandas import hashtable, tslib, lib
      /usr/local/lib/python3.5/dist-packages/allauth/account/templatetags/account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
      DeprecationWarning)
      /usr/local/lib/python3.5/dist-packages/allauth/socialaccount/templatetags/socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
      " {% load socialaccount %}", DeprecationWarning)
      Using MXNet backend.
      /usr/lib/python3/dist-packages/pandas/init.py:7: DeprecationWarning: bad escape \s
      from pandas import hashtable, tslib, lib
      /usr/local/lib/python3.5/dist-packages/allauth/account/templatetags/account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
      DeprecationWarning)
      /usr/local/lib/python3.5/dist-packages/allauth/socialaccount/templatetags/socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
      " {% load socialaccount %}", DeprecationWarning)
      Operations to perform:
      Apply all migrations: account, admin, auth, authtoken, automl, contenttypes, environments, project, projects, reversion, sessions, sites, socialaccount
      Running migrations:
      No migrations to apply.
      [2018-05-15 15:45:36 +0000] [148] [INFO] Starting gunicorn 19.6.0
      [2018-05-15 15:45:36 +0000] [148] [INFO] Listening at: http://127.0.0.1:8000 (148)
      [2018-05-15 15:45:36 +0000] [148] [INFO] Using worker: threads
      [2018-05-15 15:45:36 +0000] [167] [INFO] Booting worker with pid: 167
      yarn run v1.3.2
      $ theia start --hostname 0.0.0.0 --root-dir=/data/1/
      [I 15:45:36.936 NotebookApp] Writing notebook server cookie secret to /root/.local/share/jupyter/runtime/notebook_cookie_secret
      [I 15:45:37.122 NotebookApp] Serving notebooks from local directory: /data/1
      [I 15:45:37.122 NotebookApp] 0 active kernels
      [I 15:45:37.122 NotebookApp] The Jupyter Notebook is running at:
      [I 15:45:37.122 NotebookApp] http://0.0.0.0:8888/?token=
      [I 15:45:37.122 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
      [W 15:45:37.122 NotebookApp] No web browser found: could not locate runnable browser.
      Starting server worker…

Server worker has been started. [ID: 1 | PID: 200]

Using MXNet backend.

  • Running on http://127.0.0.1:6666/ (Press CTRL+C to quit)
    Server worker is ready to accept messages. [ID: 1 | PID: 200]

[2018-05-15T15:45:38.046Z] INFO: Theia/200 on d6f30307e6a3: Theia app listening on http://0.0.0.0:3000. []

Received message which is neither a response nor a notification message:
“3000”

[2018-05-15T15:45:38.341Z] INFO: Theia/200 on d6f30307e6a3:
[nsfw-watcher: 237] Started watching: /home/theia/examples/browser/package.json
[]

/usr/local/lib/python3.5/dist-packages/sklearn/cross_validation.py:44: DeprecationWarning: This module was deprecated in version 0.18 in favor of the model_selection module into which all the refactored classes and functions are moved. Also note that the interface of the new CV iterators are different from that of this module. This module will be removed in 0.20.
“This module will be removed in 0.20.”, DeprecationWarning)
Using MXNet backend.
Traceback (most recent call last):
File “./backend/monitor.py”, line 6, in
import plateform
ImportError: No module named ‘plateform’
Sentry is attempting to send 1 pending error messages
Waiting up to 10 seconds
Press Ctrl-C to quit

ok. DLS 2.1.0 is in testing. I am wondering if you got this version as an update or you pulled it manually?

We are aware about this bug and we have pushed the fix for it.

I got the version as an update, but i deinstalled it now. I’m currently reinstalling DLS, hopefully i’ll get it working again. maybe not topic related, but is there any possibility to help and participate in the development of the project?

How can i get the docker image 2.0.0 again? if i manually pull it, it automatically pulls 2.1.0 as soon as i start DLS

I checked our update server. Seems like latest version was pushed accidentally. I have reverted the change.

You should be able to install it now and it should not update to 2.1.0 version.

Sorry about the inconvenience.

aah alright, it seems to work perfectly now, thank you very much

Hi Bratwolf,

Thanks for your offer for helping in the development of the project. Currently our product is closed source so unfortunately this is not possible.

If you would still would like to help, there are areas where you can contribute.

  1. Helping community in this forum

  2. Beta testing

  3. Adding latest pre-trained models in Keras (1.2.2 for now). You can have a repo with the list of models and we can bundle them with the release.

Let me know your interest.

Thanks
Rajendra