Installation of the Desktop Edition on Ubuntu 18.04

How to install the desktop edition on Ubuntu 18.04.
When I launch the installer, it tell me cannot install docker and to manually install docker.
I have manually installed docker and nvidia-docker on the machine but the installer still gives the same error and fails to move forward…

Any tips would be helpful

Are you able to run docker command successfully from the terminal ?

Try ‘docker ps’ or ‘docker images’ to see if $USER has permissions to run docker commands.

I have to use sudo to run docker container…

To allow current user to run docker commands, you need to add current user to docker group.

sudo usermod -aG docker $USER

Afterwards log out from your GNOME session and login back. Now the Deep Learning Studio installer should be able to execute docker commands and complete the installation.

Thank you for the quick reply, I will check and post back

Thanks,
Seems to be working, Currently on the Install Deep Learning Studio phase

Steps that I followed (from the docker docs)

  1. sudo apt-get remove docker docker-engine docker.io
  2. sudo apt-get update
  3. sudo apt-get install apt-transport-https ca-certificates curl software-properties-common
  4. curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
  5. sudo apt-key fingerprint 0EBFCD88
  6. sudo add-apt-repository "deb [arch=amd64] https://download.docker.com/linux/ubuntu artful stable"
  7. sudo apt-get update
  8. sudo apt-get install docker-ce
  9. sudo usermod -aG docker $USER
  10. Logout and log back in and open a new terminal session
  11. Checked docker installation with 'docker run hello-world`
  12. Restarted the Deep Learning Studio installation

Note: In step #6, I used artful instead of bionic or $(lsb_release -cs) since docker is not yet (at the time of this writing) released for 18.04 stable channel.

Thanks once again

Update 1:
After installation, the installer warned that nVidia docker is not available, so I tried to install it manually.
Found out that nvidia-docker package depends on docker.io package instead of docker-ce, so set 8 is modified accordingly and then installed nvidia-docker package

Update 2:
Starting the app after loading the nvidia-docker, showed the message:

GPU: Driver version mismatch. Checking GPU driver compatibility`

and in the settings section, it offered to install the nVidia driver version 384.111 (currently running 390.48).
I tried that and it messed up my system and had to reset not only the driver but also the cuda from scratch.

Next time around, I just clicked start and a couple of minutes later the instance was started and I was able to run through the example without any problems.