Not working when deploying model!


#1

Trying to get downloaded model to work on latest anaconda installed on mac osx, works fine on ubututu 16.04.

I am doing categorical predictions on a 1024 x 512 px image that is resized to 128 x 64 for the model.

The python script does not run. It gets the wrong image dimensions and crashes.

The images are resizing in the wrong direction. Also There are depreciation warnings when reading the image. Eventually, I fixed the script so it did not crash and uses the right dimensions internally. But the predictions are all off, even when using the training data. I have tried load, resize, and convert in all the ways I could find, but nothing works.

I assume this is a version issue? Any suggestion to the best way to resolving this?


#2

Got it working! Thanks to the great support! :slight_smile: It helps if you have the right environment setup :stuck_out_tongue:

Just to clarify for mac (or any other os), use a docker container, saves you a lot of frustration, and it future proofs your model.


#3

Thank you for your feedback. We will keep this in mind for future release.


#4

How did you solved your problem?