On DLS 2.1.0 I am getting GPU driver version mismatch

Hi,
I am using Ubuntu 18.04, here I am getting GPU Enabled, but “GPU: Driver version mismatch. Running in CPU mode.” So how can I use my GPU for training, logs are as below for troubleshooting.

Starting Deep Learning Studio…Starting redis-server: redis-server.

  • Starting nginx nginx
    …done.
    /home/app/start.sh: line 32: 69 Aborted (core dumped) python /home/app/gpucheck.py 2> /dev/null
    skipping cifar dataset download!
    skipping IMDB dataset download!
    skipping MNIST dataset download!
    skipping reuters dataset download!
    Using MXNet backend.
    /usr/lib/python3/dist-packages/pandas/init.py:7: DeprecationWarning: bad escape \s
    from pandas import hashtable, tslib, lib
    /usr/local/lib/python3.5/dist-packages/allauth/account/templatetags/account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
    DeprecationWarning)
    /usr/local/lib/python3.5/dist-packages/allauth/socialaccount/templatetags/socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
    " {% load socialaccount %}", DeprecationWarning)
    Migrations for ‘automl’:
    automl/migrations/0001_initial.py:
    • Create model AutoMLModel
      Migrations for ‘projects’:
      projects/migrations/0001_initial.py:
    • Create model Project
      Migrations for ‘project’:
      project/migrations/0001_initial.py:
    • Create model dataModel
    • Create model deepModel
    • Create model importModel
    • Create model paramsModel
    • Create model testModel
    • Create model trainingModel
      Migrations for ‘environments’:
      environments/migrations/0001_initial.py:
    • Create model EnvironmentModel
      Operations to perform:
      Apply all migrations: account, admin, auth, authtoken, automl, contenttypes, environments, project, projects, reversion, sessions, sites, socialaccount
      Running migrations:
      No migrations to apply.
      Using MXNet backend.
      /usr/lib/python3/dist-packages/pandas/init.py:7: DeprecationWarning: bad escape \s
      from pandas import hashtable, tslib, lib
      /usr/local/lib/python3.5/dist-packages/allauth/account/templatetags/account_tags.py:4: DeprecationWarning: {% load account_tags %} is deprecated, use {% load account %}
      DeprecationWarning)
      /usr/local/lib/python3.5/dist-packages/allauth/socialaccount/templatetags/socialaccount_tags.py:4: DeprecationWarning: {% load socialaccount_tags %} is deprecated, use {% load socialaccount %}
      " {% load socialaccount %}", DeprecationWarning)
      [2018-07-08 19:44:49 +0000] [128] [INFO] Starting gunicorn 19.6.0
      [2018-07-08 19:44:49 +0000] [128] [INFO] Listening at: “IT’S A LINK” (128)
      [2018-07-08 19:44:49 +0000] [128] [INFO] Using worker: threads
      [2018-07-08 19:44:49 +0000] [142] [INFO] Booting worker with pid: 142
      Using MXNet backend.
  • Running on “IT’S A LINK” (Press CTRL+C to quit)
    [I 19:44:53.701 NotebookApp] Writing notebook server cookie secret to /root/.local/share/jupyter/runtime/notebook_cookie_secret
    yarn run v1.3.2
    $ theia start --hostname 0.0.0.0 --root-dir=/data/1/
    [I 19:47:22.543 NotebookApp] Serving notebooks from local directory: /data/1
    [I 19:47:23.305 NotebookApp] 0 active kernels
    [I 19:47:23.306 NotebookApp] The Jupyter Notebook is running at:
    [I 19:47:23.306 NotebookApp] http://0.0.0.0:8888/?token=
    [I 19:47:23.306 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
    [W 19:47:23.948 NotebookApp] No web browser found: could not locate runnable browser.
    Starting server worker…

Server worker has been started. [ID: 1 | PID: 201]

Server worker is ready to accept messages. [ID: 1 | PID: 201]

[2018-07-08T19:48:11.798Z] INFO: Theia/201 on 7ff8d801a11b: Theia app listening on http://0.0.0.0:3000. []

Received message which is neither a response nor a notification message:
“3000”

[2018-07-08T19:48:11.962Z] INFO: Theia/201 on 7ff8d801a11b:
[nsfw-watcher: 207] Started watching: /home/theia/examples/browser/package.json
[]

What is the GPU driver version. Per the log, GPU detection script (gpucheck.py) is crashing and hence it is showing the driver version mismatch.

2.1.0 release was tested with nvidia driver version 390.48. Even if there is a newer version installed, DLS tries to use that but it is not always expected to work well. If possible, you can install 390.48.