Soda Bottle Identification Challenge


#1

The objective of this challenge is to identify which soda bottle is present in the image. We provide you a pre-labeled dataset that you will use to build and train a deep learning AI model. We will measure accuracy of your model on a private set of samples when you submit your model for evaluation.

In order to participate in this competition you will either need to download Deep Learning Studio software from http://deepcognition.ai/desktop/ on your machine or you will have to use cloud version by signing up at http://app.deepcognition.ai/login/.

Visit Soda Bottle Identification Challenge for details.

PS: Use this thread to ask any questions related to the competition.


#2

We have added Soda Bottle Dataset under Public dataset within cloud app app.deepcognition.ai

Also, we have updated the dataset on the website with some minor corrections. You can get updated dataset from following link ( Or can directly download from website)

https://s3-us-west-2.amazonaws.com/deepcognition/datasets/Soda_Bottles.zip


#3

Hi

I’m trying to run the train data, but I get errors:

TypeError : can only concatenate tuple (not “dict”) to tuple

image

This is using the MNIST classifier as a test

image

Please advise?

Thanks :slight_smile:


#4

matt, it seems you are trying the older dataset. Can you try the latest dataset zip file ?


#5

Hi,

I am unable to register for this challenge, even though I am logged in, still getting Register to Participate.

can you please suggest what could be the reason?

Regards
Gaurav


#6


#7

I believe “register == sign up” for people who haven’t sign up or used DLS ever.


#8

Thanks for organizing an interesting and engaging competition, Just few Quick questions:

  1. After looking at dataset , it look like some categories images are mixed within another category, Is it to introduce noise in dataset?
  2. How many entries a person can submit?
  3. Is there any Leaderboard showing ranking or leading Score range?
  4. Beside Score evaluation metrics, are there any other performance matrix to consider, like good accuracy with less execution time vs high accuracy with high execution time?
  5. Is there any specific range, we should aim for first entry or best entry?

#9

@Pankaj is correct. Register to participate is only for new users who did not sign up for Deep Learning Studio earlier. If you are able to login to Deep Learning Studio, there is no extra registration required.

We will try to fix this to avoid confusion.


#10
  1. The mixing is not intentional. If you do find images mixed, please send us the list of images (in a text file) which you are finding as mixed, we will check them and fix the dataset.

  2. We have added rules section in the competition. You will be limited to 5 submission per day.

  3. Yes, there will be Leaderboard available once we enable the submission form.

  4. We are only looking at accuracy on the test set as well as secret set. Execution time is not important. There is mistake in the evaluation tab. User will be required to submit the trained model (not the YAML file). Trained model can be downloaded from inference tab in DLS. Upload the same zip file for submission.

  5. There is no specific range you need to target.


#11

Training process exited abnormly

while training using inception v3


#12

Is it possible to register for the challenge now or is the time for registration is over because I cant find the Registrate to Participate button in the Soda Botle Identification Challenge link


#13

If you already have an account with DeepCognition. There is no separate registration required to participate.

Register to participate is now only visible to users who does not have account with Deep Cognition or not logged in.


#14

error message when i train:

Training process exited abnormly.

what happen?


#15

i also have the same problem even with shallow net


#16

Hi, @matt

  1. Fix path to images files in the train.csv file.
    before:
    Image Label
    ./0.jpg P.Zero

after:
Image Label
./P.Zero/0.jpg P.Zero

  1. Copy whole folder to the folder with public datasets

  2. Add meta.json file, see mnist’s file, there are specification of names inputs and outputs

studio will be able to load your dataset, but currently I am not guarantying it will connect with the model - I am still struggling…


#17

I believe when I am logged-in I should not get Register to Participate. if you check the snapshot I attached, that clearly shows I am already logged in.

Please let me know once it is fixed.


#18

Yes, we have fixed it. Register to participate is not visible now If you are logged in.


#19

I am facing problem in training my model. I used the autoML feature to build my model. But when I start training, the system free memory goes from 14GB to 0 and my laptop hangs. I tried with the public datasets and everything is working fine. What is the matter with this ? Please help.


#20

If you are using “Full Dataset” in memory option under data tab, you can try batch by batch setting.