Soda Bottle Identification Challenge


#21

I have tried the same earlier. But it did not work. Btw the data for this challenge is very less and my ram is 16 GB. Also, a bigger dataset like that of MNIST is working fine. What should I do now?


#22

In comparison to MNIST, each image is 1175 times bigger (640 * 480 * 3/(28*28)). So even being smaller dataset, it needs around 100 times more memory than MNIST to store all the images in RAM.

If you have tried batch by batch setting, then try reducing the batch size to small value. Try with value 1 first and then increase it from there.


#23

Thanks for the clarification. I resized all the images and now it’s working fine. I am getting nearly 85% accuracy.


#24

I am not able to start training. I press ’ start training ’ button. Then it shows ’ connected to compute server ’ and just stays there for all types of instances.


#25

@ManikSoni, we have checked the issue. It seems browser is blocking non-HTTPS connections to compute server.

If you are using Chrome, there is option on the right side in address bar to allow unsafe connections. Please click on that and choose “Load unsafe scripts” as a workaround for now.

30%20PM


#26

yeah after I allowed that, I was able to start training but then I got this error.

simple_bind error. Arguments: Input_0: (32, 3, 480, 640) [12:48:20] src/operator/./cudnn_convolution-inl.h:556: Check failed: e == CUDNN_STATUS_SUCCESS (9 vs. 0) cuDNN: CUDNN_STATUS_NOT_SUPPORTED Stack trace returned 10 entries: [bt] (0) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x26ac5c) [0x7f1464dcac5c] [bt] (1) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x360307d) [0x7f146816307d] [bt] (2) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x35f9add) [0x7f1468159add] [bt] (3) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x235e5b4) [0x7f1466ebe5b4] [bt] (4) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x22d5668) [0x7f1466e35668] [bt] (5) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x338a25) [0x7f1464e98a25] [bt] (6) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x20b3bd2) [0x7f1466c13bd2] [bt] (7) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x20d2a1b) [0x7f1466c32a1b] [bt] (8) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x20d6b06) [0x7f1466c36b06] [bt] (9) /usr/local/lib/python3.5/dist-packages/mxnet/libmxnet.so(+0x20d7174) [0x7f1466c37174]


#27

This error could be result of too big network to fit on GPU/System. Can you try reducing batch size and/or reducing the image size ?


#28

Can we participate without actually using DeepCognition desktop app, or its cloud services ?


#29

Model needs to be developed using Deep Learning Studio (DLS). Submission process will accept model trained only with DLS.


#30

Did you resize the images within deep cognition studio? If yes, could you tell me how to do it within DLS?


#31

Hi, @snehalvartak

First option:
Go to Dataset tab -> click on Images label button, it will show options on the right panel -> choose Resize option -> write target size, click enter. DLS will process images with OpenCV’s resize method and will update Input size in the model viewport

Second option:
Use MaxPooling2D or AveragePooling2D layer, that can be viewed (roughly) as the integer scaling of the image


#32

Could you, please, provide intermediate version of DLS with bug-fixes for pre-trained nets? So state-of-the-art nets can be used for fine tuning. With ‘include top layers’ option equal to false, fully non-trainable (Trainable=0) or fully trainable (Trainable=100). Include-top is not critical, as for me, because can be constructed manually, intermediate states for option ‘Trainable’ for me are hard to interpret what to learn and what not to learn.


#33

@Ambreaux yes, once we resolve the issue with pre-trained model weight saving (with some layers trainable), we will make a release.

As of today, fully trainable (Trainable=100) with or without top should be working.


#34

How do I install cv2 in the studio?
I am trying to import keras python code which used opencv/cv2 and getting this error. Help!!

File “backend\importKeras.py”, line 493, in importKeras
File “”, line 271, in
File “E:\Softwares\DeepLearningStudio\conda3\lib\site-packages\cv2_init_.py”, line 7, in
from . import cv2
ImportError: DLL load failed: The specified module could not be found.
Uploading to server
***FAILED.import failed


Import cv2 ; ImportError: DLL load failed: The specified module could not be found.from . import cv2 8 sys.modules['cv2'] = cv2 ImportError: DLL load failed: The specified module could not be found
#35

you can first launch bash.exe from <DLS_INSTALL_FOLDER>/usr/bin. Run below command to set the PATH.

export PATH=/usr/bin:/conda3:$PATH

After this you should be able use pip/pip3 command to install whichever package you want.


#36

Is there anyway to get additional feedback on a submission? My model has perfect accuracy on the training set and near perfect accuracy on the validation set. However, I received a score of 0.

The submission page says 1 entry per day whereas, the official rules state:
Submission Limits
You may submit a maximum of 5 entries per day.
You have to select 1 final submissions for judging.

Which is correct?


#37

How come are there already three submission from obviously the same user when there are only 1 submission permitted per day?

What are the expected time it takes to evaluate a submission?


#38

I see 2 entries by a similar username. As per rules, one participant can have only 1 account. If some users are violating that, then they will may not be eligible for the prize.

A submission takes 5-10 mins to evaluate and it can take more if there are other submissions pending.


#39

I do not see the result of my model


#40

When i upload my model in submission form, i get displayed object object and when i click submit , it starts to reupload. It would be good if it shows the percent of upload completed.